MotoHouston.com MotoHouston.com
Register Members List Member Map Media Calendar Garage Forum Home Mark Forums Read

Go Back   MotoHouston.com > Technical > How To's and Q & A's
Forgot info?

Welcome to MotoHouston.com! You are currently viewing our forums as a guest which gives you limited access to the community. By joining our free community you will have access to great discounts from our sponsors, the ability to post topics, communicate privately with other members, respond to polls, upload content, free email, classifieds, and access many other special features. Registration is fast, simple and absolutely free, join our community!

Register Today!

If you have any problems with the registration process or your account login, please contact us.


FREE MH Decals by MAIL!

Advertisement

Reply
Share This Thread: 
Subscribe to this Thread Thread Tools
Old 08-17-2017, 10:05 PM   #1
KraftMoto
#repthekraft
 
KraftMoto's Avatar
 
Join Date: Jul 2017
Location: Katy, TX
Feedback Rating: (0)
Posts: 61

Experience: 10+ years

Bike(s):
2004 CBR F4i
2009 Harley Davidson Street Bob
2014 Harley Davidson Iron 883







Need help

Ok so I just got my bike back from the shop.

They replaced my ignition because previous owner plugged up a unknown ignition with no resistor in it so he hardwired a 9v battery into it to allow the fuel pump to kick on.
Well that's all replaced now.


This problem has been an issue but I was hoping it was just an ignition problem.

The bike doesn't realize it's in Neutral and I have to play with the gear shifter for the bike to recognize it's in neutral when starting. And then when I go to put the kickstand up the bike shuts off. It's ruff idle the moment it starts and sometimes even takes multiple tries to get it to turn over.

Please help! Any ideas or fixes to this problem?!

04 F4i
KraftMoto is offline   Reply With Quote
Advertisement
Old 08-18-2017, 06:10 AM   #2
pbfoot
Senior Member
 
pbfoot's Avatar
 
Join Date: Jun 2014
Location: Webster
Feedback Rating: (0)
Posts: 810

Experience: 10+ years

Bike(s):
2006 Kawasaki ZG1000









Clean the sidestand safety switch with WD40.

Last edited by pbfoot; 08-18-2017 at 06:11 AM. Reason: Msp
pbfoot is offline   Reply With Quote
Liked this post:
Old 08-18-2017, 07:22 AM   #3
William Wolfen
Senior Member
 
William Wolfen's Avatar
 
Join Date: Jul 2016
Location: Cypress, TX
Feedback Rating: (0)
Posts: 250

Experience: 2 years

Bike(s):
2015 Suzuki DR650









Or bypass said kickstand switch.

The neutral issue sounds like the known problem with the DR650 I have. The neutral sending unit inside the engine is known to get loose and eventually drop it's screws inside the case. Might want to look up if there's a similar potential for the F4I.
__________________
2015 Suzuki DR650
2010 Ducati Hypermotard Evo SP - For Sale
William Wolfen is online now   Reply With Quote
Liked this post:
Old 08-18-2017, 09:36 AM   #4
KraftMoto
#repthekraft
 
KraftMoto's Avatar
 
Join Date: Jul 2017
Location: Katy, TX
Feedback Rating: (0)
Posts: 61

Experience: 10+ years

Bike(s):
2004 CBR F4i
2009 Harley Davidson Street Bob
2014 Harley Davidson Iron 883







Need help

Ok, adding: it has no problem starting when it's cold.


Also, can I cut these shorter and not worry about anything
KraftMoto is offline   Reply With Quote
Old 08-18-2017, 10:04 AM   #5
pbfoot
Senior Member
 
pbfoot's Avatar
 
Join Date: Jun 2014
Location: Webster
Feedback Rating: (0)
Posts: 810

Experience: 10+ years

Bike(s):
2006 Kawasaki ZG1000









Quote:
Originally Posted by KraftMoto View Post
Ok, adding: it has no problem starting when it's cold.


Also, can I cut these shorter and not worry about anything
Yes.
pbfoot is offline   Reply With Quote
Reply


Thread Tools

Advertisement


All times are GMT -5. The time now is 02:12 PM.


MotoHouston.com is not responsible for the content posted by users.
Privacy Policy