Welcome back to us :/ Our hosts data center was down for the entire day.
MotoHouston.com MotoHouston.com
Register Members List Member Map Media Calendar Garage Forum Home Mark Forums Read

Go Back   MotoHouston.com > Technical > Performance and Modifications
Forgot info?

Welcome to MotoHouston.com! You are currently viewing our forums as a guest which gives you limited access to the community. By joining our free community you will have access to great discounts from our sponsors, the ability to post topics, communicate privately with other members, respond to polls, upload content, free email, classifieds, and access many other special features. Registration is fast, simple and absolutely free, join our community!

Register Today!

If you have any problems with the registration process or your account login, please contact us.


FREE MH Decals by MAIL!

Advertisement

Reply
Share This Thread: 
Subscribe to this Thread Thread Tools
Old 05-06-2009, 10:53 PM   #21
Captain
The Beast
 
Captain's Avatar
 
Join Date: May 2008
Location: On The Streets
Feedback Rating: (0)
Posts: 1,441

Experience: 5 years
Trackdays: 1

Bike(s):
GSX-R 1000




Member Garage





I had a friend install mine and they work good but some times I can go some where and stop or turn of my bike come back and they don't work. then move the wires and they work....this sucks who can help me fix my problem.
Captain is offline   Reply With Quote
Similar Topics
Thread Thread Starter Forum Replies Last Post
HID Lights Patrick Motorcycles Unlimited 5 12-08-2011 11:21 PM
Where can I get HID's/Custom lights installed on my bike?? venmichaels General Discussion (Moto Related) 28 07-13-2011 12:53 PM
Hid Lights agarcia08 Performance and Modifications 13 01-23-2009 10:21 AM
HID lights handozizle Performance and Modifications 22 06-12-2006 01:19 PM
Advertisement
Old 05-07-2009, 12:01 AM   #22
Japawhat02
02 Tona
 
Japawhat02's Avatar
 
Join Date: Feb 2007
Location: P-land
Feedback Rating: (1)
Posts: 6,941

Experience: 3 years
Trackdays: 3

Bike(s):
2002 Daytona









sounds like a bad connection. I would just go through and make sure everything is nice and tight. Also might put some electrical connection grease on the connectors. Sorry dont remeber the actual name of the stuff.
Di electric grease????
__________________
2002 Brittish Rocket
Japawhat02 is offline   Reply With Quote
Reply


Thread Tools

Advertisement


All times are GMT -5. The time now is 05:51 PM.


MotoHouston.com is not responsible for the content posted by users.
Privacy Policy