MotoHouston.com MotoHouston.com
Register Members List Member Map Media Calendar Garage Forum Home Mark Forums Read

Go Back   MotoHouston.com > General Discussion > General Discussion (Moto Related)
Forgot info?

Welcome to MotoHouston.com! You are currently viewing our forums as a guest which gives you limited access to the community. By joining our free community you will have access to great discounts from our sponsors, the ability to post topics, communicate privately with other members, respond to polls, upload content, free email, classifieds, and access many other special features. Registration is fast, simple and absolutely free, join our community!

Register Today!

If you have any problems with the registration process or your account login, please contact us.


FREE MH Decals by MAIL!

Advertisement

Reply
Share This Thread: 
Subscribe to this Thread Thread Tools
Old 04-12-2009, 08:38 AM   #1
flip326
No likey, no bikey
 
flip326's Avatar
 
Join Date: May 2005
Location: League City
Feedback Rating: (0)
Posts: 5,509

Experience: 7 years
Trackdays: 9

Bike(s):
'07 GSXR-750 (sold)
'05 zx6r Monster (sold)
'03 600rr track (sold)
'04 600rr Eurobet (sold)
'05 gsxr 600 (sold)






03 600rr Brake Light/ Turn Signal problem

I noticed that both my turn signals do not turn on at all, the blinker indicator above the tach doens't blink, front and rear, left and right, nothing blinks.

I also noticed that either my brake light is stuck "on", and won't go back to idle.


Is this a fuse problem?


I have LED front and rear turn signals, and was told that I may need a 20 Watt 8 ohm resistor hooked up to the front turn signals to get them to work properly. But they worked fine for about 3 months before they went out.
__________________
flip326 is offline   Reply With Quote
Similar Topics
Thread Thread Starter Forum Replies Last Post
Brake light problem cbrmonkey How To's and Q & A's 7 01-20-2013 06:51 PM
HALP! Please read! IT/brake light problem The Black Sheepdog General Discussion (Moto Related) 11 03-06-2011 01:49 AM
03-04 600rr Integrated Brake/Turn signals flip326 General Discussion (Moto Related) 0 07-23-2010 08:05 PM
rear signal-brake light integration DVLDGSXR6 General Discussion (Moto Related) 6 07-15-2008 09:59 PM
Broken signal light on 600rr re-verse How To's and Q & A's 6 07-01-2007 11:09 AM
Advertisement
Old 04-12-2009, 08:51 AM   #2
CaligoneTx
Forest Gnome Tour Guide
 
CaligoneTx's Avatar
 
Join Date: Sep 2007
Location: Valhalla
Feedback Rating: (1)
Posts: 21,558

Experience: 10+ years

Bike(s):
Triumph 675r
Ducati 748
Hyosungs (250r + 650r)
Honda 900rr
Suzuki Busa1300r (+2 bikes)






Send a message via AIM to CaligoneTx Send a message via Yahoo to CaligoneTx
If there isn't enough amperage through the load, the relay wont click on and off. a relay is just a piece of metal that heats up when the amperage of the blinker bulbs/leds and resister go through it. Metal expands, and curls up(clicks) cools, and drops back down and makes contact.

If the amperage in the system isn't enough or no lights are connected(no load) the Light on the instrument cluster would not come on.

Since the signal light is not coming on, either the switch is not providing the information or yes, you have a faulty power supply. Check owners manual for fuse locations, check the fuse. then begin to check outputs.
__________________
triumphsig
CaligoneTx is offline   Reply With Quote
Old 04-12-2009, 09:56 AM   #3
FLYIN'DUC
Senior Member
 
FLYIN'DUC's Avatar
 
Join Date: Apr 2007
Location: Cleveland, Texas
Feedback Rating: (7)
Posts: 6,254


Bike(s):
07 Ducati, 99 Busa









I agree with Matt 100% I would check fuse first, also brake light problem is prolly totally seperate problem, probably not going back stop off position, try pushing brake lever back and pulling pedal up, could be sticky or need adjusting, gl
FLYIN'DUC is offline   Reply With Quote
Old 04-12-2009, 10:02 AM   #4
flip326
No likey, no bikey
 
flip326's Avatar
 
Join Date: May 2005
Location: League City
Feedback Rating: (0)
Posts: 5,509

Experience: 7 years
Trackdays: 9

Bike(s):
'07 GSXR-750 (sold)
'05 zx6r Monster (sold)
'03 600rr track (sold)
'04 600rr Eurobet (sold)
'05 gsxr 600 (sold)






after doing some research, i found that the brake light,. turn signal, and horn are all on the same fuse.

went into the garage, pulled the fairing off, and saw a blown fuse. i replaced it, and it now works again.

thx for the heads up.
__________________
flip326 is offline   Reply With Quote
Reply


Thread Tools

Advertisement


All times are GMT -5. The time now is 07:40 PM.


MotoHouston.com is not responsible for the content posted by users.
Privacy Policy