MotoHouston.com MotoHouston.com
Register Members List Member Map Media Calendar Garage Forum Home Mark Forums Read

Go Back   MotoHouston.com > Technical > How To's and Q & A's
Forgot info?

Welcome to MotoHouston.com! You are currently viewing our forums as a guest which gives you limited access to the community. By joining our free community you will have access to great discounts from our sponsors, the ability to post topics, communicate privately with other members, respond to polls, upload content, free email, classifieds, and access many other special features. Registration is fast, simple and absolutely free, join our community!

Register Today!

If you have any problems with the registration process or your account login, please contact us.


Like us on Facebook! Regular shirt GIVEAWAYS and more

Advertisement

Reply
Share This Thread: 
Subscribe to this Thread Thread Tools
Old 12-21-2007, 06:26 PM   #1
Dgig
Senior Member
 
Dgig's Avatar
 
Join Date: Jul 2007
Location: humble
Feedback Rating: (1)
Posts: 648


Bike(s):
06 gsxr 600









06 gsxr FI light

my light comes on the fi I was told its the injector light but the bike doesent run different its just that light is annoying the out of me need to know what I can do and about how much,, some times I can shut her off and turn it back on and it goes a way but last night it just stayed on all the dam time please help...
Dgig is offline   Reply With Quote
Similar Topics
Thread Thread Starter Forum Replies Last Post
07 gsxr 600 red light and fi flashing eric636 How To's and Q & A's 15 04-23-2011 09:37 AM
06 zx6 FI light is on gsxrcody General Discussion (Moto Related) 4 11-24-2010 02:35 AM
06 GSXR 600 F1 light help... Helios How To's and Q & A's 8 10-01-2009 10:38 AM
FI light on k6 gsxr 600 tsuki zuki How To's and Q & A's 0 10-19-2008 06:36 PM
'07 (or '06) gixxer 6 or 7 help - rpm indicator light (rev light/shift light) issanni How To's and Q & A's 9 02-27-2007 03:28 PM
Advertisement
Old 12-21-2007, 06:38 PM   #2
Mr. Unassailable
1-20-2013-Change we need
 
Join Date: Oct 2006
Feedback Rating: (6)
Posts: 19,792

Experience: 10+ years
Trackdays: 10+






Member Garage





mine does the same. LMK if you get some tips.
__________________
Retired
tracksig
Mr. Unassailable is offline   Reply With Quote
Old 12-21-2007, 06:42 PM   #3
Pre-K
Senior Member
 
Pre-K's Avatar
 
Join Date: Mar 2007
Location: Tomball
Feedback Rating: (11)
Posts: 3,413

Experience: 1-3 months
Trackdays: 10+

Bike(s):
2012 CBR1000RR
2014 Specialized








Easy fix dood... I had an '06 600 and had the same problem.

What happens is this: the two cables (running from the 'lil electric motor under your passenger seat to the butterfly valve right before your exhaust) get "bogged down". When they get stuck, the butterfly valve won't open/close as it should, so you get the "FI" light. There is nothing wrong with your engine...

The cables are routed weird and you just have to route them as straight as possible from the 'lil motor to the butterfly valve. You'll probably have to use a few zip ties to help out, but when you're done, you'll never have an "FI" code again! Yay!
Pre-K is offline   Reply With Quote
Old 12-21-2007, 06:45 PM   #4
Pre-K
Senior Member
 
Pre-K's Avatar
 
Join Date: Mar 2007
Location: Tomball
Feedback Rating: (11)
Posts: 3,413

Experience: 1-3 months
Trackdays: 10+

Bike(s):
2012 CBR1000RR
2014 Specialized








Or if you go with any of the slip-on exhausts out there, that will eliminate the butterfly valve completely. Then you can just unbolt the 'lil motor under the seat and pull out the cables.

I'd recommend that since you lose 10-11 lbs when you ditch the stock catty-littick converter/exhaust thingy...
Pre-K is offline   Reply With Quote
Old 12-21-2007, 06:46 PM   #5
txgsxrbob
THE SH*T STARTER IS BACK
 
Join Date: Nov 2007
Location: 290 @ mason --cypress
Feedback Rating: (0)
Posts: 5,859


Bike(s):
06 GSXR 1K SOLD !
2012 R1 Moto GP replica # 1287








Quote:
Originally Posted by Pre-K View Post
Easy fix dood... I had an '06 600 and had the same problem.

What happens is this: the two cables (running from the 'lil electric motor under your passenger seat to the butterfly valve right before your exhaust) get "bogged down". When they get stuck, the butterfly valve won't open/close as it should, so you get the "FI" light. There is nothing wrong with your engine...

The cables are routed weird and you just have to route them as straight as possible from the 'lil motor to the butterfly valve. You'll probably have to use a few zip ties to help out, but when you're done, you'll never have an "FI" code again! Yay!
+1
__________________
Quote:
Originally Posted by abelrob View Post
I would join in but my KAWI is BROKE THE FU*K down again SO I BOUGHT A BUSA !!
Quote:
Originally Posted by pester View Post
NOW WHERE IS TXGSXRBOB WHEN WE NEED HIM????
txgsxrbob is offline   Reply With Quote
Old 12-21-2007, 06:52 PM   #6
Dgig
Senior Member
 
Dgig's Avatar
 
Join Date: Jul 2007
Location: humble
Feedback Rating: (1)
Posts: 648


Bike(s):
06 gsxr 600









yea I dont have the doe for exhuast to eliminate that so what I do with the wires the exhuast I want is about 450
Dgig is offline   Reply With Quote
Old 12-21-2007, 06:53 PM   #7
Dgig
Senior Member
 
Dgig's Avatar
 
Join Date: Jul 2007
Location: humble
Feedback Rating: (1)
Posts: 648


Bike(s):
06 gsxr 600









the red dot me off
Dgig is offline   Reply With Quote
Old 12-21-2007, 06:55 PM   #8
txgsxrbob
THE SH*T STARTER IS BACK
 
Join Date: Nov 2007
Location: 290 @ mason --cypress
Feedback Rating: (0)
Posts: 5,859


Bike(s):
06 GSXR 1K SOLD !
2012 R1 Moto GP replica # 1287








If you buy anew system it will have inst. on what wire to cut for when you install your pipe..
__________________
Quote:
Originally Posted by abelrob View Post
I would join in but my KAWI is BROKE THE FU*K down again SO I BOUGHT A BUSA !!
Quote:
Originally Posted by pester View Post
NOW WHERE IS TXGSXRBOB WHEN WE NEED HIM????
txgsxrbob is offline   Reply With Quote
Old 12-21-2007, 09:08 PM   #9
Pre-K
Senior Member
 
Pre-K's Avatar
 
Join Date: Mar 2007
Location: Tomball
Feedback Rating: (11)
Posts: 3,413

Experience: 1-3 months
Trackdays: 10+

Bike(s):
2012 CBR1000RR
2014 Specialized








Just give the cables as straight a path as possible so they don't bind. From the factory, mine were all twisted and jacked and bent up.

Can't remember but I think you MAY have to remove the tail section (plastics, not the sub-frame) to get to the 'lil motor. Pretty simple, though...

I'd be happy to help you if my instructions suck!
Pre-K is offline   Reply With Quote
Old 12-21-2007, 09:12 PM   #10
Dgig
Senior Member
 
Dgig's Avatar
 
Join Date: Jul 2007
Location: humble
Feedback Rating: (1)
Posts: 648


Bike(s):
06 gsxr 600









okay
Dgig is offline   Reply With Quote
Old 12-21-2007, 09:49 PM   #11
Patrick
Motorcycles Unlimited
 
Join Date: Jun 2005
Location: Houston
Feedback Rating: (2)
Posts: 16,367

Experience: 10+ years
Trackdays: 10+

Bike(s):
'14 Speed Triple R, '82 CB900F, '13 Streetglide






The FI light on the Suzuki can be anything from a loose connection to a bad exhaust servo motor.

If you bring it by. I'll read the code for you and let you know what it is. No charge.
__________________
Call or PM for the BEST PRICES in Houston for PARTS and ACCESSORIES.
MAKE SURE TO MENTION YOU'RE ON MH TO GET THE BEST PRICE!

NEED GEAR? We have a great selection in stock but if we need to order it we GUARANTEE FIT!
Where Houston riders go to have their bikes worked on, done right the first time!


muad

1964 FM 1960 West
Houston, TX 77090
Hours: Tues.-Fri. 9:30-6:00 Sat. 9-5:30
www.motorcycles-unlimited.com
http://www.facebook.com/motorcyclesunlimited
e-mail: patrick@motorcycles-unlimited.com
Patrick is offline   Reply With Quote
Old 12-22-2007, 08:05 PM   #12
Dgig
Senior Member
 
Dgig's Avatar
 
Join Date: Jul 2007
Location: humble
Feedback Rating: (1)
Posts: 648


Bike(s):
06 gsxr 600









cool thanks I will as soon as I can
Dgig is offline   Reply With Quote
Old 12-22-2007, 08:15 PM   #13
HoustonGixxer
Senior Member
 
Join Date: Aug 2007
Feedback Rating: (17)
Posts: 5,225

Experience: 8 years
Trackdays: 10+






Member Garage





you just need to get a new bike and give me yours lol
HoustonGixxer is offline   Reply With Quote
Old 12-22-2007, 10:05 PM   #14
carlos flores
WE DONT DIE...WE MULTIPLY
 
carlos flores's Avatar
 
Join Date: Apr 2007
Location: SE HOUSTON/ THE GET DOWN DENA..pasadena
Feedback Rating: (1)
Posts: 1,625

Experience: 3 years

Bike(s):
06 gixxer sixxer









mine does the same thing dude......!
carlos flores is offline   Reply With Quote
Old 12-22-2007, 10:36 PM   #15
Dgig
Senior Member
 
Dgig's Avatar
 
Join Date: Jul 2007
Location: humble
Feedback Rating: (1)
Posts: 648


Bike(s):
06 gsxr 600









HA ha houston Gixer get your own big balla, one with the red dot light those are the best gixers mostly06- 07
Dgig is offline   Reply With Quote
Old 12-22-2007, 10:55 PM   #16
Zrob25
Senior Member
 
Zrob25's Avatar
 
Join Date: Oct 2006
Feedback Rating: (0)
Posts: 501












Mine has done this a few times. I just turn off the key and start up again and it goes away.
__________________
"I'm your Huckleberry!"
Zrob25 is offline   Reply With Quote
Old 12-22-2007, 10:59 PM   #17
Dgig
Senior Member
 
Dgig's Avatar
 
Join Date: Jul 2007
Location: humble
Feedback Rating: (1)
Posts: 648


Bike(s):
06 gsxr 600









yea I turn it off agian and start it up to but some times mor recently it wong go off have to restart to many times then it just stay on first time it happened I rode from galveston with it on I was freakin out had me all of 06 and a red light on but now I know its not that seroius I will get it fixed any way
Dgig is offline   Reply With Quote
Old 12-22-2007, 11:40 PM   #18
Pre-K
Senior Member
 
Pre-K's Avatar
 
Join Date: Mar 2007
Location: Tomball
Feedback Rating: (11)
Posts: 3,413

Experience: 1-3 months
Trackdays: 10+

Bike(s):
2012 CBR1000RR
2014 Specialized








Quote:
Originally Posted by dany rosu View Post
yea I turn it off agian and start it up to but some times mor recently it wong go off have to restart to many times then it just stay on first time it happened I rode from galveston with it on I was freakin out had me all of 06 and a red light on but now I know its not that seroius I will get it fixed any way
Shouldn't hurt your bike, but it will rob you of some power... you'll either be running low rpm with the butterfly valve fully open (and have less torque) or be running high rpm with the butterfly valve partially closed (and have less horse-power)...
Pre-K is offline   Reply With Quote
Old 12-23-2007, 12:23 AM   #19
YZFracer212
Senior Member
 
YZFracer212's Avatar
 
Join Date: Nov 2005
Location: Deer Park
Feedback Rating: (1)
Posts: 1,089


Bike(s):
05 SV 1000 ~ Street, 2000 SV 650 ~ track, 2007 RMZ 250 ~ MX, 2003 CRF 88 ~ play









Send a message via AIM to YZFracer212
on the new 600, putting an aftermarket exhaust will leave the butter-fly. It was the 05 06 1000s that removed the valve
YZFracer212 is offline   Reply With Quote
Old 12-23-2007, 12:39 AM   #20
Zrob25
Senior Member
 
Zrob25's Avatar
 
Join Date: Oct 2006
Feedback Rating: (0)
Posts: 501












Did you buy it new? Should be under warranty. I got 5 yrs on mine
__________________
"I'm your Huckleberry!"
Zrob25 is offline   Reply With Quote
Reply


Thread Tools

Advertisement


All times are GMT -5. The time now is 07:08 PM.


MotoHouston.com is not responsible for the content posted by users.
Privacy Policy