MotoHouston.com MotoHouston.com
Register Members List Member Map Media Calendar Garage Forum Home Mark Forums Read

Go Back   MotoHouston.com > General Discussion > General Discussion (Moto Related)
Forgot info?

Welcome to MotoHouston.com! You are currently viewing our forums as a guest which gives you limited access to the community. By joining our free community you will have access to great discounts from our sponsors, the ability to post topics, communicate privately with other members, respond to polls, upload content, free email, classifieds, and access many other special features. Registration is fast, simple and absolutely free, join our community!

Register Today!

If you have any problems with the registration process or your account login, please contact us.


Like us on Facebook! Regular shirt GIVEAWAYS and more

Advertisement

Reply
Share This Thread: 
Subscribe to this Thread Thread Tools
Old 09-17-2014, 12:23 PM   #1
KneeSlider
Member
 
Join Date: Nov 2013
Location: NorthWest Houston
Feedback Rating: (0)
Posts: 84

Experience: 1 year

Bike(s):
2007 ZX-6R
1999 Suzuki SV650(stolen)
2009 Ninja 650R







07 zx6r Oil Leak From water pump

so about to leave the house i pull my bike out into the wet floor, noticed oil has spilled EVERYWHERE when i start the bike, its coming from the water pump
KneeSlider is offline   Reply With Quote
Similar Topics
Thread Thread Starter Forum Replies Last Post
electric water pump? bioGuru Car Forum 8 05-29-2014 12:51 PM
water pump test eckzwolfe How To's and Q & A's 7 07-22-2012 09:14 PM
water pump Japawhat02 Off Topic 2 05-14-2012 04:21 PM
Water pump help? gtdrivr Off Topic 12 11-19-2010 11:35 PM
Water Pump WarrenW How To's and Q & A's 0 08-19-2010 01:23 PM
Advertisement
Old 09-17-2014, 12:25 PM   #2
KneeSlider
Member
 
Join Date: Nov 2013
Location: NorthWest Houston
Feedback Rating: (0)
Posts: 84

Experience: 1 year

Bike(s):
2007 ZX-6R
1999 Suzuki SV650(stolen)
2009 Ninja 650R







from the weeping hole under the water pump
KneeSlider is offline   Reply With Quote
Old 09-17-2014, 12:38 PM   #3
40acres
Senior Member
 
Join Date: Apr 2014
Location: Tomball, TX
Feedback Rating: (0)
Posts: 1,085


Bike(s):
2008 zx-6r
2011 kx250f
2006 zx-6r (R.I.P.)
2004 RM 125 (sold)






I'm not aware of any "weeping" hole under the water pump, but my first guess would most likely the mechanical seal inside the water pump. Pictures would help as well. Is it pouring out of that hole? Is is leaking from the top down? Valve cover gasket (common problem)> Oil filter too loose? Like I said, pics will help alot.

http://www.partzilla.com/parts/searc...TER/parts.html
40acres is offline   Reply With Quote
Old 09-17-2014, 12:48 PM   #4
40acres
Senior Member
 
Join Date: Apr 2014
Location: Tomball, TX
Feedback Rating: (0)
Posts: 1,085


Bike(s):
2008 zx-6r
2011 kx250f
2006 zx-6r (R.I.P.)
2004 RM 125 (sold)






Well, since I can't edit my previous post (mods, this is retarded btw)... It appears that there is a weep hole. Your most likely culprit will be the mechanical/oil seal in the water pump. You'll also need to check your coolant and oil for signs of cross contamination.
40acres is offline   Reply With Quote
Old 09-17-2014, 12:50 PM   #5
KneeSlider
Member
 
Join Date: Nov 2013
Location: NorthWest Houston
Feedback Rating: (0)
Posts: 84

Experience: 1 year

Bike(s):
2007 ZX-6R
1999 Suzuki SV650(stolen)
2009 Ninja 650R







Quote:
Originally Posted by 40acres View Post
I'm not aware of any "weeping" hole under the water pump, but my first guess would most likely the mechanical seal inside the water pump. Pictures would help as well. Is it pouring out of that hole? Is is leaking from the top down? Valve cover gasket (common problem)> Oil filter too loose? Like I said, pics will help alot.

http://www.partzilla.com/parts/searc...TER/parts.html
yeah i cleaned it all up and noticed it coming from behind the waterpump, most definitely a bad seal, gotta look up the manual
KneeSlider is offline   Reply With Quote
Old 09-17-2014, 12:52 PM   #6
bun1t
Senior Member
 
bun1t's Avatar
 
Join Date: Apr 2010
Feedback Rating: (0)
Posts: 485

Experience: 8 years
Trackdays: 5

Bike(s):
Gen 4 ZX10R
Honda Grom








Quote:
Originally Posted by 40acres View Post
I'm not aware of any "weeping" hole under the water pump, but my first guess would most likely the mechanical seal inside the water pump. Pictures would help as well. Is it pouring out of that hole? Is is leaking from the top down? Valve cover gasket (common problem)> Oil filter too loose? Like I said, pics will help alot.

http://www.partzilla.com/parts/searc...TER/parts.html
Yeah they have a weep hole for the oil to exit instead of going into the coolant.

If it's anything like the Z1000 ones good luck. They're a to get to seal. After going through 3 seals on my brothers bike, I just just bought a used water pump and changed the whole thing
bun1t is offline   Reply With Quote
Old 09-17-2014, 12:53 PM   #7
KneeSlider
Member
 
Join Date: Nov 2013
Location: NorthWest Houston
Feedback Rating: (0)
Posts: 84

Experience: 1 year

Bike(s):
2007 ZX-6R
1999 Suzuki SV650(stolen)
2009 Ninja 650R







hopefully i can get it back by next weekend

Last edited by KneeSlider; 09-17-2014 at 12:56 PM.
KneeSlider is offline   Reply With Quote
Reply


Thread Tools

Advertisement


All times are GMT -5. The time now is 03:09 AM.


MotoHouston.com is not responsible for the content posted by users.
Privacy Policy