MotoHouston.com MotoHouston.com
Register Members List Member Map Media Calendar Garage Forum Home Mark Forums Read

Go Back   MotoHouston.com > Technical > How To's and Q & A's
Forgot info?

Welcome to MotoHouston.com! You are currently viewing our forums as a guest which gives you limited access to the community. By joining our free community you will have access to great discounts from our sponsors, the ability to post topics, communicate privately with other members, respond to polls, upload content, free email, classifieds, and access many other special features. Registration is fast, simple and absolutely free, join our community!

Register Today!

If you have any problems with the registration process or your account login, please contact us.


Like us on Facebook! Regular shirt GIVEAWAYS and more

Advertisement

Reply
Share This Thread: 
Subscribe to this Thread Thread Tools
Old 07-15-2014, 12:42 AM   #1
j0nathan
Senior Member
 
j0nathan's Avatar
 
Join Date: Jan 2014
Location: galleria area
Feedback Rating: (0)
Posts: 129

Experience: 4-8 months

Bike(s):
04 GSXR 750









k4 gsxr 750 stva fix

Has anyone done the stva fix? I don't really have any experience soldering or i would do it myself.
j0nathan is offline   Reply With Quote
Similar Topics
Thread Thread Starter Forum Replies Last Post
K4 gsxr 750 won't start j0nathan How To's and Q & A's 32 08-15-2014 11:24 PM
gsxr 600 STVA problem tony66 How To's and Q & A's 1 11-06-2013 11:07 PM
05 gsxr 600 STVA kevintx88 Performance and Modifications 1 08-06-2012 12:18 PM
Another Project K4 Gsxr 600 RayBusa Taking it to the Track 14 06-12-2012 12:01 PM
k4 GSXR 750: gauge cluster, turn signals, and headlights all quit together!? andrave How To's and Q & A's 8 10-02-2008 01:49 PM
Reply


Thread Tools

Advertisement


All times are GMT -5. The time now is 07:05 AM.


MotoHouston.com is not responsible for the content posted by users.
Privacy Policy