MotoHouston.com MotoHouston.com
Register Members List Member Map Media Calendar Garage Forum Home Mark Forums Read

Go Back   MotoHouston.com > General Discussion > General Discussion (Moto Related)
Forgot info?

Welcome to MotoHouston.com! You are currently viewing our forums as a guest which gives you limited access to the community. By joining our free community you will have access to great discounts from our sponsors, the ability to post topics, communicate privately with other members, respond to polls, upload content, free email, classifieds, and access many other special features. Registration is fast, simple and absolutely free, join our community!

Register Today!

If you have any problems with the registration process or your account login, please contact us.


FREE MH Decals by MAIL!

Advertisement

Reply
Share This Thread: 
Subscribe to this Thread Thread Tools
Old 06-12-2014, 12:52 PM   #1
dpberdo17
Member
 
Join Date: Mar 2011
Feedback Rating: (0)
Posts: 56












I need your help!!

I have a 2004 gsxr that I need help with. I think it's a short but I really have no idea. My head, rear, and dash lights all went out. Idk what to do!!!! Any help is much appreciated.
dpberdo17 is offline   Reply With Quote
Advertisement
Old 06-12-2014, 01:14 PM   #2
bumblebee
Yeah I'm flippin' YOU off
 
bumblebee's Avatar
 
Join Date: Oct 2006
Location: Pearland
Feedback Rating: (3)
Posts: 12,268


Bike(s):
'74 Suzuki GT380
'82 XS650 StreetTracker
'10 Ducati Streetfighter
'83 Yamaha Seca 900






Check fuses?
Check battery connections?
Check ground connections?
Check wire harness for loose connections or chafed wires?
Does it run?
Fuel pump run?
__________________
Asphalt is for racing... dirt is for growing potatoes. - J. Diester
When seconds count... the police are only minutes away.
Grow up and be a productive member of society already.
Bevo- "I lack skillz"
bumblebee is offline   Reply With Quote
Old 06-12-2014, 01:15 PM   #3
tiatool
Pro Racer Mode Enabled
 
tiatool's Avatar
 
Join Date: Apr 2008
Location: Gunspoint
Feedback Rating: (14)
Posts: 8,710

Experience: 10+ years
Trackdays: 10+

Bike(s):
08 Raven
05 Vstar 1100





Fuse
__________________
sbmsafesig
tiatool is online now   Reply With Quote
Old 06-12-2014, 01:19 PM   #4
r6racer
track
 
r6racer's Avatar
 
Join Date: Dec 2012
Location: Houston
Feedback Rating: (4)
Posts: 8,582

Experience: 2 years
Trackdays: 10+

Bike(s):
2008 Yamaha R6 Race/track
2012 Yamaha WGP R6
2004 Kawasaki KLx250 2-stroke
2008 Yamaha R6 Street *Sold*
2005 Yamaha R6 Track *Sold*

Member Garage





Take it to house of paint if you cant figure it out
r6racer is offline   Reply With Quote
Old 06-12-2014, 01:41 PM   #5
Coolhandsluke
Senior Member
 
Coolhandsluke's Avatar
 
Join Date: Oct 2013
Location: Northside-Northline
Feedback Rating: (0)
Posts: 854

Experience: 1-3 months
Trackdays: 1

Bike(s):
04 Gsxr 600
01 XR50 mini tard
01 XR650R SM
01 KDX 200






Deja vu could have sworn I just replied to this thread...

When it happened to mine a part of the headlights wiring harness had burned out and had melted together where the diff wires come together. Shop wanted to charge me out the azz plus spend a few hundred on a new harness.

I had no headlights, tachometer, spedo, my brakes lights and blinkers worked.

Got a used harness online for 70 bucks and a family friend replaced the burned out with stuff from the new(to me) harness.

If I wasn't as mechanically inclined as a potato I could explain this much better lol.

There's two wiring harnesses for your bike btw.

GoodguyCraig gave me a hand with it originally but we were looking in the wrong place and had replaced the main harness that runs through the body of the bike instead of the one up front.
__________________
\_(ツ)_/
If it flies, floats or you're better off renting.
Coolhandsluke is offline   Reply With Quote
Old 06-12-2014, 01:52 PM   #6
dpberdo17
Member
 
Join Date: Mar 2011
Feedback Rating: (0)
Posts: 56












Everything works as far as driving. The turn signals, speedometer, etc is what's out. I I checked the fuses and they were fine.
dpberdo17 is offline   Reply With Quote
Reply


Thread Tools

Advertisement


All times are GMT -5. The time now is 09:21 PM.


MotoHouston.com is not responsible for the content posted by users.
Privacy Policy