MotoHouston.com MotoHouston.com
Register Members List Member Map Media Calendar Garage Forum Home Mark Forums Read

Go Back   MotoHouston.com > Technical > How To's and Q & A's
Forgot info?

Welcome to MotoHouston.com! You are currently viewing our forums as a guest which gives you limited access to the community. By joining our free community you will have access to great discounts from our sponsors, the ability to post topics, communicate privately with other members, respond to polls, upload content, free email, classifieds, and access many other special features. Registration is fast, simple and absolutely free, join our community!

Register Today!

If you have any problems with the registration process or your account login, please contact us.


FREE MH Decals by MAIL!

Advertisement

Reply
Share This Thread: 
Subscribe to this Thread Thread Tools
Old 05-25-2014, 04:25 AM   #1
hondarider77
Senior Member
 
hondarider77's Avatar
 
Join Date: Sep 2007
Location: Cypress
Feedback Rating: (0)
Posts: 3,155

Experience: 10+ years

Bike(s):
2007 cbr1000rr
2005 crf450r
2005 crf150f
2005 crf150f tarded
2008 r6






Send a message via AIM to hondarider77
Ninja 300 trouble.

Got the motor in the ninja. Compression is good, new plugs, fresh gas, fresh oil. It revs perfectly in neutral but when you ride, it won't rev past 8000 rpm. Any ideas?
hondarider77 is offline   Reply With Quote
Similar Topics
Thread Thread Starter Forum Replies Last Post
Kawasaki Ninja 300 new vs 300/250 user piosta General Discussion (Moto Related) 29 03-24-2015 09:50 AM
Kawasaki is Recalling 11,097 Ninja 300 and 300 ABS motorcycles Patrick General Discussion (Moto Related) 27 08-17-2013 09:51 PM
First Bike - Ninja 300 Rowdy76 General Discussion (Moto Related) 26 04-19-2013 05:45 PM
Do want... Ninja 300... cychotic General Discussion (Moto Related) 45 09-26-2012 12:49 AM
2002 Ninja 250 having trouble idleing albertogti117 How To's and Q & A's 11 03-09-2011 04:06 PM
Advertisement
Old 05-25-2014, 08:28 AM   #2
cuong-nutz
Resident 250 guru
 
cuong-nutz's Avatar
 
Join Date: Mar 2009
Feedback Rating: (9)
Posts: 4,569

Experience: 1-3 months

Bike(s):
Ninjer 250









Does acceleration feel normal until it hits 8k? It won't go past 8k no matter how much you twist the throttle in first gear an second gear? Does it feel like it hits a brick wall/fuel cut-off?

Loose injector wires? Coils? Damaged Ecu? Has the Ecu been replaced? There was a recall that affected the Ecu. I do not know the exact nature of the recall though.
__________________
250cc's of pure Nutz
Ninjette Stunt Life Stunt Ride
cuong-nutz is offline   Reply With Quote
Old 05-25-2014, 09:02 AM   #3
BYRDMAN
WX MAN
 
BYRDMAN's Avatar
 
Join Date: Apr 2006
Location: Houston
Feedback Rating: (8)
Posts: 9,311

Trackdays: 10+

Bike(s):
2015 KTM Adventure 1190
2007 KTM 300 XC smoker
2007 KTM 300 XC smoker


Member Garage





sounds like a Throttle position sensor problem....is there a way to reset it or relearn it?
__________________
If you can read this, thank a teacher, because its in English, thank a soldier"

AMERICAN MADE WITH MEXICAN PARTS
BYRDMAN is offline   Reply With Quote
Old 05-25-2014, 12:07 PM   #4
hondarider77
Senior Member
 
hondarider77's Avatar
 
Join Date: Sep 2007
Location: Cypress
Feedback Rating: (0)
Posts: 3,155

Experience: 10+ years

Bike(s):
2007 cbr1000rr
2005 crf450r
2005 crf150f
2005 crf150f tarded
2008 r6






Send a message via AIM to hondarider77
I'm not sure. I've done some research on a similar issue and its came down to maybe a bad kickstand switch or restricted airflow.
hondarider77 is offline   Reply With Quote
Old 05-25-2014, 01:13 PM   #5
hondarider77
Senior Member
 
hondarider77's Avatar
 
Join Date: Sep 2007
Location: Cypress
Feedback Rating: (0)
Posts: 3,155

Experience: 10+ years

Bike(s):
2007 cbr1000rr
2005 crf450r
2005 crf150f
2005 crf150f tarded
2008 r6






Send a message via AIM to hondarider77
I took the air box cover off. No difference. And I also spliced the kickstand switch together. No better. Also I noticed a rattle noise coming from the throttle body area.
hondarider77 is offline   Reply With Quote
Old 05-25-2014, 06:14 PM   #6
cuong-nutz
Resident 250 guru
 
cuong-nutz's Avatar
 
Join Date: Mar 2009
Feedback Rating: (9)
Posts: 4,569

Experience: 1-3 months

Bike(s):
Ninjer 250









Make sure the boots are secure to prevent a vacuum leak.
__________________
250cc's of pure Nutz
Ninjette Stunt Life Stunt Ride
cuong-nutz is offline   Reply With Quote
Old 05-25-2014, 06:58 PM   #7
hondarider77
Senior Member
 
hondarider77's Avatar
 
Join Date: Sep 2007
Location: Cypress
Feedback Rating: (0)
Posts: 3,155

Experience: 10+ years

Bike(s):
2007 cbr1000rr
2005 crf450r
2005 crf150f
2005 crf150f tarded
2008 r6






Send a message via AIM to hondarider77
Will check tomorrow with some throttle body spray for a vacuum leak. Hey buddy I got an extra parts to that other motor if you want it
hondarider77 is offline   Reply With Quote
Old 05-25-2014, 07:57 PM   #8
TheMagicMan
SBN Mechanic
 
TheMagicMan's Avatar
 
Join Date: Mar 2007
Location: NW Houston
Feedback Rating: (7)
Posts: 4,292

Experience: 10+ years
Trackdays: 10+

Bike(s):
'97-DR650 '01-RC51 '03-XR250R '83-XR80R '93-XR80R '03-XR50









Possible ground issue as well.
TheMagicMan is offline   Reply With Quote
Old 05-25-2014, 08:03 PM   #9
hondarider77
Senior Member
 
hondarider77's Avatar
 
Join Date: Sep 2007
Location: Cypress
Feedback Rating: (0)
Posts: 3,155

Experience: 10+ years

Bike(s):
2007 cbr1000rr
2005 crf450r
2005 crf150f
2005 crf150f tarded
2008 r6






Send a message via AIM to hondarider77
As far as I can see its only got 2 ground connections and the are both rust/ paint free and tight
hondarider77 is offline   Reply With Quote
Reply


Thread Tools

Advertisement


All times are GMT -5. The time now is 05:57 AM.


MotoHouston.com is not responsible for the content posted by users.
Privacy Policy