MotoHouston.com MotoHouston.com
Register Members List Member Map Media Calendar Garage Forum Home Mark Forums Read

Go Back   MotoHouston.com > General Discussion > General Discussion (Moto Related)
Forgot info?

Welcome to MotoHouston.com! You are currently viewing our forums as a guest which gives you limited access to the community. By joining our free community you will have access to great discounts from our sponsors, the ability to post topics, communicate privately with other members, respond to polls, upload content, free email, classifieds, and access many other special features. Registration is fast, simple and absolutely free, join our community!

Register Today!

If you have any problems with the registration process or your account login, please contact us.


FREE MH Decals by MAIL!

Advertisement

Reply
Share This Thread: 
Subscribe to this Thread Thread Tools
Old 05-26-2013, 05:56 PM   #1
darranwil
Rev_Psilocybe
 
darranwil's Avatar
 
Join Date: Feb 2013
Location: Deep Ellum
Feedback Rating: (0)
Posts: 944

Experience: 2 years

Bike(s):
2004 Buell Xb12s
2002 Buell Blast-(sold)
87 Honda Rebel 450 (sold)


Member Garage





Never trust the manual

F'ing Factory Service Manuals.

Got to love when the oil send and return line routings in the manual are backwards. Just got the buell blast back together after a few days of head scratching. Glad I didn't let her run for more than a few mins. I expect this from a chilton of Hayes manual but not the factory manual for the dealership techs. Explains alot...
__________________
Rev
darranwil is offline   Reply With Quote
Similar Topics
Thread Thread Starter Forum Replies Last Post
Why I really only riding with those I trust!! UniFiddy Super Motards 10 06-29-2014 10:40 AM
what news do you trust? Chris24 Off Topic 19 10-22-2009 12:10 PM
would you trust this?? Duck84 General Discussion (Moto Related) 26 04-16-2008 12:13 AM
YOU CAN TRUST A DOG FastLine Off Topic 5 09-12-2007 12:56 PM
Do you trust me? ArturoC Off Topic 1 09-23-2006 07:20 PM
Advertisement
Old 05-26-2013, 06:52 PM   #2
El Pachuco
Senior Member
 
El Pachuco's Avatar
 
Join Date: May 2012
Location: 30 miles south of downtown
Feedback Rating: (0)
Posts: 835

Experience: 10+ years
Trackdays: 10+

Bike(s):
Kawasaki ZRX 1200R









WOW!! that is a big mistake. i'd be very off.
El Pachuco is offline   Reply With Quote
Old 05-26-2013, 07:40 PM   #3
darranwil
Rev_Psilocybe
 
darranwil's Avatar
 
Join Date: Feb 2013
Location: Deep Ellum
Feedback Rating: (0)
Posts: 944

Experience: 2 years

Bike(s):
2004 Buell Xb12s
2002 Buell Blast-(sold)
87 Honda Rebel 450 (sold)


Member Garage





Yeah. I went over it several times. Even looked for an updated version online but couldnt find one. Eventually used my external electronic brain, le googlie, to confirm on the oil pump side in and return. As soon as I pulled that line and no oil came out, went back and checked manual again, yup, I did it exactly like they had it marked. Flipped the 2 lines, of course with oil still in the tank (dry sump), made a mess but expected. Cleaned her up and started her up. TACKA TACKA TACKA TACKA PURRRRRRRRRRRRR. What me off the most is I had already replaced this engine with a used one and thought it had a bad oil pump. So figured I might as well rebuild the entire thing, dropped that one, and rebuilt the original one since I had the time right now. Test ride around hood tomorrow and hopefully back on 2 wheels tomorrow. Parts come in on the Big Boy Buell wednesday so I'll be on the baby Buell for a week while I rebuild that engine. It's been 2 weeks and I'm getting the shakes, I need my bike!
__________________
Rev
darranwil is offline   Reply With Quote
Reply


Thread Tools

Advertisement


All times are GMT -5. The time now is 02:07 AM.


MotoHouston.com is not responsible for the content posted by users.
Privacy Policy