MotoHouston.com MotoHouston.com
Register Members List Member Map Media Calendar Garage Forum Home Mark Forums Read

Go Back   MotoHouston.com > Technical > How To's and Q & A's
Forgot info?

Welcome to MotoHouston.com! You are currently viewing our forums as a guest which gives you limited access to the community. By joining our free community you will have access to great discounts from our sponsors, the ability to post topics, communicate privately with other members, respond to polls, upload content, free email, classifieds, and access many other special features. Registration is fast, simple and absolutely free, join our community!

Register Today!

If you have any problems with the registration process or your account login, please contact us.


Like us on Facebook! Regular shirt GIVEAWAYS and more

Advertisement

Reply
Share This Thread: 
Subscribe to this Thread Thread Tools
Old 05-13-2012, 11:02 PM   #1
txgsxrboi
C-Ward
 
txgsxrboi's Avatar
 
Join Date: May 2012
Feedback Rating: (0)
Posts: 9

Experience: 2 years

Bike(s):
03 gsxr 600









Dropping RPMs and FI light

I have FI and will be putting into dealer mode tomorrow with a paperclip, but am curious if a loose kickstand spring can cause an FI light. My bike suddenly dropped RPMs to 0 in gears 4 and 5 but did not kill. No response from throttle and five seconds later returned to normal to whatever RPM related to my throttle position. This has happened 3 times. I am hoping it's just my kickstand spring allowing the vibrations at higher RPMs to drop it a little and cause the RPM stutter. I will be bypassing my kickstand sensor tomorrow to see if that solves the issue. Has anyone else had a similar problem? any help/comments are appreciated.
__________________
"Be careful, don't speed"

Me:
txgsxrboi is offline   Reply With Quote
Similar Topics
Thread Thread Starter Forum Replies Last Post
FI light troubles, Help! EnzoMaranello Performance and Modifications 5 09-15-2012 02:51 PM
fi light code SouthrnSmkd How To's and Q & A's 17 11-22-2009 01:30 AM
FI light turned on.. Help! mikes-si How To's and Q & A's 7 01-01-2009 06:55 PM
whats FI light tonkatrucks40 How To's and Q & A's 8 11-10-2008 04:22 PM
FI Light SPHINX How To's and Q & A's 6 11-07-2007 09:24 PM
Advertisement
Old 05-13-2012, 11:05 PM   #2
BRYAN
Big and Cranky...
 
BRYAN's Avatar
 
Join Date: Oct 2009
Location: halfway to nowhere
Feedback Rating: (2)
Posts: 3,256

Experience: 10+ years
Trackdays: 10+

Bike(s):
A Trackbike
Another Trackbike
A Motard







i suggest taking to a shop before you go shoving paperclips into it.
__________________
BRYAN is offline   Reply With Quote
Old 05-13-2012, 11:07 PM   #3
txgsxrboi
C-Ward
 
txgsxrboi's Avatar
 
Join Date: May 2012
Feedback Rating: (0)
Posts: 9

Experience: 2 years

Bike(s):
03 gsxr 600









Quote:
Originally Posted by BRYAN View Post
i suggest taking to a shop before you go shoving paperclips into it.
Eh, i have the schematics and walk through for getting to dealer mode and it's very promising. Costs $85 just to get the code at the dealership near me and a paper clip seems like a very affordable and viable option.
__________________
"Be careful, don't speed"

Me:
txgsxrboi is offline   Reply With Quote
Old 05-13-2012, 11:14 PM   #4
Harveyj
Senior Member
 
Harveyj's Avatar
 
Join Date: Aug 2011
Location: Jersey Village
Feedback Rating: (0)
Posts: 206

Experience: 6 years

Bike(s):
2003 ZX12-R
2006 LTR 450
2001 KX 250
2006 GSXR 600
2003 ZZR 1200






the paper clip should at least tell you if it is the problem, but it almost sounds like a loose wire, bad connection?
Harveyj is offline   Reply With Quote
Old 05-13-2012, 11:15 PM   #5
Harveyj
Senior Member
 
Harveyj's Avatar
 
Join Date: Aug 2011
Location: Jersey Village
Feedback Rating: (0)
Posts: 206

Experience: 6 years

Bike(s):
2003 ZX12-R
2006 LTR 450
2001 KX 250
2006 GSXR 600
2003 ZZR 1200






post the schmatic if you can.
Harveyj is offline   Reply With Quote
Old 05-13-2012, 11:26 PM   #6
txgsxrboi
C-Ward
 
txgsxrboi's Avatar
 
Join Date: May 2012
Feedback Rating: (0)
Posts: 9

Experience: 2 years

Bike(s):
03 gsxr 600









I have considered a loose wire or connection maybe relating to my ignition module as I had a spill awhile back. Also did a full fairing kit replacement myself and maybe wiggled something loose by accident. The kickstand sensor was the cheapest/easiest fix to start with. I posted the schematic. it is simply to jump the dealer connector to get into dealer mode yourself with a paper clip rather than paying for the "special machine". Should give me the C code right off. Will post tomorrow after trying it out.
Attached Thumbnails
Click image for larger version

Name:	ecu_01_800.jpg
Views:	46
Size:	36.8 KB
ID:	56327  
__________________
"Be careful, don't speed"

Me:
txgsxrboi is offline   Reply With Quote
Old 05-13-2012, 11:44 PM   #7
CraigRR
CMRA # 147
 
CraigRR's Avatar
 
Join Date: Mar 2011
Location: Crosby
Feedback Rating: (3)
Posts: 8,868

Experience: 10+ years
Trackdays: 10+

Bike(s):
2009 Honda CBR 1000RR ABS
2011 EX250NinjaR
2001 Yamaha TTR-L (sold to Jimrad)
2015 KTM RC 390 CUP






It could be something with your throttle intake assembly. Are you loosing power after 7000 rpm?
__________________
BRAWP
CraigRR is offline   Reply With Quote
Old 05-14-2012, 06:28 AM   #8
Harveyj
Senior Member
 
Harveyj's Avatar
 
Join Date: Aug 2011
Location: Jersey Village
Feedback Rating: (0)
Posts: 206

Experience: 6 years

Bike(s):
2003 ZX12-R
2006 LTR 450
2001 KX 250
2006 GSXR 600
2003 ZZR 1200






Quote:
Originally Posted by txgsxrboi View Post
I have considered a loose wire or connection maybe relating to my ignition module as I had a spill awhile back. Also did a full fairing kit replacement myself and maybe wiggled something loose by accident. The kickstand sensor was the cheapest/easiest fix to start with. I posted the schematic. it is simply to jump the dealer connector to get into dealer mode yourself with a paper clip rather than paying for the "special machine". Should give me the C code right off. Will post tomorrow after trying it out.
yeah the paper clip will be fine. if you can can you post all the schematic? I was wanting to look and see what else could be causeing your problems. Hope the paper clip fixes it
Harveyj is offline   Reply With Quote
Old 05-14-2012, 08:02 PM   #9
txgsxrboi
C-Ward
 
txgsxrboi's Avatar
 
Join Date: May 2012
Feedback Rating: (0)
Posts: 9

Experience: 2 years

Bike(s):
03 gsxr 600









Quote:
Originally Posted by craig_gsxr600 View Post
It could be something with your throttle intake assembly. Are you loosing power after 7000 rpm?
From what i've noticed the three times it's happened you're dead on. It seems to only happen past 7k rpm and not EVERYtime. I'm at work right now and haven't had a chance to get the FI code off my bike.
__________________
"Be careful, don't speed"

Me:
txgsxrboi is offline   Reply With Quote
Old 05-14-2012, 10:59 PM   #10
DLSGAP
Whats the "Dragon"
 
DLSGAP's Avatar
 
Join Date: Mar 2009
Location: Midlothian, TX
Feedback Rating: (0)
Posts: 361

Experience: 10+ years
Trackdays: 10+

Bike(s):
'11 FZ8









Will the fi code remain until its cleared? Its possible it could be coming on when the motor cuts out just due to a loss of fuel pressure.

I've had lots of friends with gsxr's that had issues with their side stand switch causing the bike to die while riding, but since its still in gear, it just chuggs along for a sec turning the motor and effectively bumpstarting itself and you're back riding again before ya know it. But if you've already replaced that i dunno
__________________
-Damien

"If loud pipes save lives, imagine what learning to ride that thing could do for you "
DLSGAP is offline   Reply With Quote
Old 05-23-2012, 03:27 AM   #11
txgsxrboi
C-Ward
 
txgsxrboi's Avatar
 
Join Date: May 2012
Feedback Rating: (0)
Posts: 9

Experience: 2 years

Bike(s):
03 gsxr 600









I've found out it is in fact my kick stand sensor. My spring is old allowing the stand to drop just enough to cause a complete drop in rpms. it happened today and i reached down and pulled my kickstand up with my foot and solved the issue instantly. I haven't had time to bypass the sensor but am doing that tomorrow morning.
__________________
"Be careful, don't speed"

Me:
txgsxrboi is offline   Reply With Quote
Old 05-23-2012, 11:36 AM   #12
txgsxrboi
C-Ward
 
txgsxrboi's Avatar
 
Join Date: May 2012
Feedback Rating: (0)
Posts: 9

Experience: 2 years

Bike(s):
03 gsxr 600









Just finished bypassing the switch. Completely solved the problem. no more dropping rpms anywhere on my powerband or in any gear. Thanks for all the suggestions.
__________________
"Be careful, don't speed"

Me:
txgsxrboi is offline   Reply With Quote
Reply


Thread Tools

Advertisement


All times are GMT -5. The time now is 01:45 AM.


MotoHouston.com is not responsible for the content posted by users.
Privacy Policy