Welcome back to us :/ Our hosts data center was down for the entire day.
MotoHouston.com MotoHouston.com
Register Members List Member Map Media Calendar Garage Forum Home Mark Forums Read

Go Back   MotoHouston.com > General Discussion > General Discussion (Moto Related)
Forgot info?

Welcome to MotoHouston.com! You are currently viewing our forums as a guest which gives you limited access to the community. By joining our free community you will have access to great discounts from our sponsors, the ability to post topics, communicate privately with other members, respond to polls, upload content, free email, classifieds, and access many other special features. Registration is fast, simple and absolutely free, join our community!

Register Today!

If you have any problems with the registration process or your account login, please contact us.


FREE MH Decals by MAIL!

Advertisement

Reply
Share This Thread: 
Subscribe to this Thread Thread Tools
Old 10-02-2011, 11:59 PM   #1
ivancuriel
Sancho Pedotes
 
ivancuriel's Avatar
 
Join Date: Apr 2010
Feedback Rating: (4)
Posts: 647

Experience: 1-3 months
Trackdays: 1

Bike(s):
2009 Yamaha R6 Raven.
2012 Yamaha R1 Moto GP Edition





Bugs on engine?

I turned on my bike this morning to go for a ride and suddenly smoke started coming from the engine, it was a nasty smell, not like plastic or oil or anything, but like burning flesh. I don't know if a lizard crawled into the engine and once the engine heated it it got stuck not sure. I couldn't tell if anything was in side because everything so compact and I didn't feel like taking off the fairings.

The engine stopped smoking after a minute or two and rode around everything seemed fine. Has anyone else had a problem like this? My entire garage smells like now
ivancuriel is offline   Reply With Quote
Similar Topics
Thread Thread Starter Forum Replies Last Post
Gladiator Bugs NgaWhat Off Topic 2 02-08-2012 12:38 AM
Bugs Pyrofallout Forum Updates & Feedback 9 07-09-2010 10:34 PM
Bed Bugs BabyGirlGSXR Off Topic 35 05-17-2009 12:01 AM
Attn: Shutter Bugs Swift E Off Topic 50 03-04-2008 04:36 PM
got bugs? CBR RN General Discussion (Moto Related) 12 06-09-2006 06:00 PM
Advertisement
Old 10-03-2011, 12:45 AM   #2
kevintx88
too slow too furious
 
kevintx88's Avatar
 
Join Date: Jun 2011
Location: cypress
Feedback Rating: (0)
Posts: 564

Experience: 2 years

Bike(s):
05 gsxr600 20th anniversary edition









This year especially bad cause of the drought. Everything hatches at once since we got some rain. Bugs everywhere! Havnt washed my car lately cause it would be bug covered in a few mins afterwards.

Sent from my DROIDX using Tapatalk
kevintx88 is offline   Reply With Quote
Reply


Thread Tools

Advertisement


All times are GMT -5. The time now is 11:32 PM.


MotoHouston.com is not responsible for the content posted by users.
Privacy Policy