Register Members List Member Map Media Calendar Garage Forum Home Mark Forums Read

Go Back > General Discussion > General Discussion (Moto Related)
Forgot info?

Welcome to! You are currently viewing our forums as a guest which gives you limited access to the community. By joining our free community you will have access to great discounts from our sponsors, the ability to post topics, communicate privately with other members, respond to polls, upload content, free email, classifieds, and access many other special features. Registration is fast, simple and absolutely free, join our community!

Register Today!

If you have any problems with the registration process or your account login, please contact us.

FREE MH Decals by MAIL!


Share This Thread: 
Subscribe to this Thread Thread Tools
Old 10-01-2011, 07:19 PM   #1
Yeah i can get it up
AYEELE's Avatar
Join Date: Aug 2007
Location: houston
Feedback Rating: (7)
Posts: 3,088

Experience: 6 years

08 1000rr
silver 04 r6(stunt)
Black 03 600rr(sold)
White and pink 06 r6

Does anyone work on clusters?(speedo)

I got a 06 r6 and the tachometer is off sync. it was working perfectly fine till today. the needle is just everywhere sometimes, sometimes it just sticks, and sometimes it works just fine. i made sure all connections are tight and snugg. Any help would do

Last edited by AYEELE; 10-01-2011 at 07:22 PM.
AYEELE is offline   Reply With Quote
Similar Topics
Thread Thread Starter Forum Replies Last Post
Hayabusa Speedo EWG78 How To's and Q & A's 17 04-09-2012 08:03 PM
Speedo Issue atexanone General Discussion (Moto Related) 23 06-21-2010 07:17 PM
Speedo- Who Needs It? Squoddybody General Discussion (Moto Related) 23 02-09-2009 01:20 PM
Anyway to test gauge clusters? Robert95z General Discussion (Moto Related) 3 01-07-2007 09:26 PM
speedo swim_ags How To's and Q & A's 8 02-01-2006 02:16 PM

Thread Tools


All times are GMT -5. The time now is 07:09 AM. is not responsible for the content posted by users.
Privacy Policy