Register Members List Member Map Media Calendar Garage Forum Home Mark Forums Read

Go Back > Technical > How To's and Q & A's
Forgot info?

Welcome to! You are currently viewing our forums as a guest which gives you limited access to the community. By joining our free community you will have access to great discounts from our sponsors, the ability to post topics, communicate privately with other members, respond to polls, upload content, free email, classifieds, and access many other special features. Registration is fast, simple and absolutely free, join our community!

Register Today!

If you have any problems with the registration process or your account login, please contact us.

FREE MH Decals by MAIL!


Share This Thread: 
Subscribe to this Thread Thread Tools
Old 05-29-2011, 07:43 PM   #1
Join Date: May 2011
Feedback Rating: (0)
Posts: 15

04 cbr 1000 RR wiring issue

Need to rewire the instrument cluster so that when disconnected from the wiring harness the bike doesn't stop running.

Anyone know of an end plug or a way to close the circuit so that the bike will run without the instrument cluster?

Rdslvr04 is offline   Reply With Quote
Similar Topics
Thread Thread Starter Forum Replies Last Post
04-07 cbr 1000 jti slip on exhaust Himynameis Performance and Modifications 2 03-18-2015 11:36 AM
i need help purchasing a 2014 cbr 1000 rr!! zikaprevail General Discussion (Moto Related) 23 03-09-2014 01:17 AM
'04 CBR 600RR Regulator/Rectifier Issue? TomballD General Discussion (Moto Related) 10 02-23-2013 11:59 AM
*** NEED HELP *** honda cbr 900rr issue greentegr6 How To's and Q & A's 18 05-12-2008 04:50 PM
Need Help 04 r6 transmission or clutch issue? bagedtaco General Discussion (Moto Related) 3 03-30-2008 12:56 AM

Thread Tools


All times are GMT -5. The time now is 07:27 AM. is not responsible for the content posted by users.
Privacy Policy