Register Members List Member Map Media Calendar Garage Forum Home Mark Forums Read

Go Back > Technical > How To's and Q & A's
Forgot info?

Welcome to! You are currently viewing our forums as a guest which gives you limited access to the community. By joining our free community you will have access to great discounts from our sponsors, the ability to post topics, communicate privately with other members, respond to polls, upload content, free email, classifieds, and access many other special features. Registration is fast, simple and absolutely free, join our community!

Register Today!

If you have any problems with the registration process or your account login, please contact us.

FREE MH Decals by MAIL!


Share This Thread: 
Subscribe to this Thread Thread Tools
Old 01-24-2011, 10:19 AM   #1
Senior Member
logan5's Avatar
Join Date: Feb 2007
Location: Friendswood
Feedback Rating: (5)
Posts: 5,805

2001 SV 650 (my track ), 2005 SV 650s

SV650 electrical problems ... help if you can ...

So ... was working on the wire harness to install a new instrument cluster on my '05 SV650, and I think I screwed something up major ...

When I turn the ignition to ON, the fuel pump doesn't come on ... I can crank the motor with the starter button, but obviously with no fuel it doesn't catch.

So I quickly put my old cluster back and while it does light up I get no infor on the LCD and the red engine light that usually comes on at startup no longer apears.

All my other indicators appear to work (neutral, blinkers and highlights)

Any thoughts are much appreciated ... I hope I didn't fry my ECM ...
Ben Franklin once told us that “The Constitution only gives people the right to pursue happiness. You have to catch it yourself.”
"Blessed are the young for they shall inherit the national debt" Herbert Hoover
logan5 is offline   Reply With Quote
Similar Topics
Thread Thread Starter Forum Replies Last Post
04 636- confusing electrical problems joeylowlife How To's and Q & A's 5 04-19-2014 03:12 PM
electrical problems 2007 gsxr 750 battery dead will713 How To's and Q & A's 9 09-19-2013 08:07 PM
2003 F4i electrical problems? Jaycub Performance and Modifications 8 04-25-2012 03:27 PM
01 SV650 electrical issues zombiejesus General Discussion (Moto Related) 15 12-16-2010 09:03 PM
Electrical Problems Hotwheelscamaro How To's and Q & A's 14 10-03-2006 07:45 PM
Old 01-24-2011, 08:03 PM   #2
Senior Member
Join Date: Apr 2007
Feedback Rating: (0)
Posts: 887

Check fuses.
Vividkid is offline   Reply With Quote

Thread Tools


All times are GMT -5. The time now is 06:01 AM. is not responsible for the content posted by users.
Privacy Policy