Register Members List Member Map Media Calendar Garage Forum Home Mark Forums Read

Go Back > General Discussion > General Discussion (Moto Related)
Forgot info?

Welcome to! You are currently viewing our forums as a guest which gives you limited access to the community. By joining our free community you will have access to great discounts from our sponsors, the ability to post topics, communicate privately with other members, respond to polls, upload content, free email, classifieds, and access many other special features. Registration is fast, simple and absolutely free, join our community!

Register Today!

If you have any problems with the registration process or your account login, please contact us.

FREE MH Decals by MAIL!


Share This Thread: 
Subscribe to this Thread Thread Tools
Old 08-09-2010, 01:06 PM   #1
Senior Member
Join Date: May 2007
Location: The Woodlands
Feedback Rating: (0)
Posts: 416

Experience: 3 years

2010 Ducati Streetfighter S
2009 Ninja 250

Temperature sensor issues?

Friday on the way home from work my check engine light popped on and the temp gauge was blinking low. It would continue for a moment and then return to a normal reading. After a moment the light would turn off. This only happened right after I made a turn and was traveling above 80 miles per hour indicated.

Well, today on the way to work it happened even in a straight line. It seemed to be indicating running cooler than normal as well and would drop temp as I increased speed. Over very large bumps (at speed) the CEL would pop on and the temp gauge would flash low, repeating back and forth for a few minutes to reading a temp and then dropping back to flashing. After a few minutes straight with no disturbance it will turn off the light.

I've searched a bit and found similar instances but with no resolution. The dealers are closed on Mondays here. Any ideas?

I've checked oil and coolant and everything seems ok. I tooled around on Saturday and couldn't get the problem to replicate, but I never went over 60 miles an hour. It did seem to be indicating it was running cool, though. There's no way it's running too cold; it was 103 out here on Saturday.

Help. :(
Phiber is offline   Reply With Quote
Similar Topics
Thread Thread Starter Forum Replies Last Post
Tire Temperature Bevo General Discussion (Moto Related) 65 01-24-2013 09:02 PM
Temperature? flipstyledsm22 How To's and Q & A's 4 10-23-2011 10:46 PM
Daytona Temperature Sensor Jason_Canuck General Discussion (Moto Related) 0 09-14-2009 08:11 AM
Temperature on bike lnghrn4lif General Discussion (Moto Related) 6 06-09-2009 09:00 AM
temperature stickers Mad Max Dirtbikes, Mini's, ATV's..... 0 08-11-2007 03:19 AM
Old 08-09-2010, 01:14 PM   #2
Senior Member
Mr.D's Avatar
Join Date: Apr 2010
Location: Med Center
Feedback Rating: (1)
Posts: 4,532

Experience: 5 years

ZZR 600
2007 GSXR 600
VFR 800
Honda Stunt 50


I honestly can't provide a decent help here. I just wanted to make myself feel like I didn't waste time reading this.

Patrick is a Ducati expert. He should know.
In Hoc Signo Vinces. 1855
Mr.D is offline   Reply With Quote

Thread Tools


All times are GMT -5. The time now is 10:19 PM. is not responsible for the content posted by users.
Privacy Policy